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1 Introduction & Benefits 
 
1.1 Welcome 
 
Welcome to Infoplex’s SIM (System Integration Manager) for use with the TAS range of accounting 
products and Infoplex software modules.  With over 85,000 TAS customers in the UK and Ireland, 
TAS is one of the top three systems for SMEs (Small and Medium-sized Enterprises). 
 
SIM is the one stop manager for handling TAS integration, security, setup, user configuration, 
versioning and licensing for all Infoplex integration software, including OrderBooks®, MultiTAS™, 
TASflex™ and TASLink™ SDK. 
 
Infoplex integration software for TAS can be implemented as individual software modules to provide 
significant enhancements and cost savings for TAS users.  Full details can be found in the relevant 
manuals as listed below: 
 

Reference Manual Integration Software 
System Integration Manager SIM - this manual 

MultiTAS Sales Ledger 
MultiTAS Purchase Ledger 
MultiTAS Cash Book 

MultiTAS Financial Ledgers 

MultiTAS Nominal Ledger 
MultiTAS Stock & Order Processing MultiTAS Stock, Bill of Materials, Sales Order and 

EDI/XML Link 
TASflex Seamless Real-time integration from TASLink 

packages for end-users 
TASLink SDK - Software Development Kit 
eBanking/BACS eBanking/BACS for TAS Purchase Ledger 
HSBC EDI Sales Invoice Finance HSBC EDI Sales Invoice Finance 
[Bespoke] Bespoke packages 

 
 
1.2 Key Features & Benefits 
 
Although SIM itself does not provide any direct TAS data processing, which is handled by individual 
software modules, it does have several of its own features and benefits: 
 

# Feature Benefit 
1 Modular design You only pay for the features and 

functions that you need 
2 Single Login Convenient and time saving, SIM saves 

you having to login to (and out of) each 
TAS company separately 

3 Powerful User Management Quickly add or discontinue users and their 
access rights - temporarily or permanently 
- at both the global level and at the 
software/company level, as needed 

4 Crystal Reports Template Editor Easily customise reports and documents 
used throughout MultiTAS, OrderBooks 
and many other database driven systems. 

5 Fast Installation/Update Rapidly install software modules and 
updates from simple website downloads 

6 Flexible Activation Options Simply activate (register and upgrade) SIM 
and software modules independently of 
each other from single screen 
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1.3 Licensing 
 
1.3.1 Infoplex Software 
 
When you install SIM, OrderBooks, MultiTAS, TASflex or TASLink you are asked to agree to the 
Infoplex Software Licence Agreement.  A copy of this is installed in your SIM program installation 
folder with the filename “Licence.txt”. 
 
 
1.3.2 Licensing format 
 
SIM and its related software are available in a similar licensing format to TAS systems: 
 

# Licence element Notes 
1 User You can install and run the software on any computer but 

only for use by the maximum number of concurrent users at 
any one time for which you have paid licence fees. 
NB: a single user licence still lets you set up several different 
users – but only one can be logged in at any time. 

2 Company dataset You can install and run the software on any computer but 
only for use with the maximum number of sets of data, 
whether company, partnership, group, person or otherwise, 
for which you have paid licence fees. 

3 Purpose The most common purpose is for internal business purposes, 
but different licences are available for software development 
and business service or bureau operations 

4 Option Optional extra “Special Features” can be purchased and 
licensed individually. 

 
 
1.3.3 7-Zip GNU LGPL 
 
SIM uses parts of the 7-Zip program, which is licensed under the GNU LGPL licence.  You can find 
the source code for 7-Zip at www.7-zip.org as well as other information. 

http://www.7-zip.org/
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1.4 System Organisation 
 
SIM must be installed and run separately on each PC.  The main SIM program file “SIMgr.exe” and its 
dependent component files are stored and started locally on the PC, usually from a folder called 
“C:\Program Files\Infoplex\SIM” or, in legacy systems, “C:\InfHome”. 
 
In a standalone (normally = single user) environment, SIM’s database files are stored in 
“C:\Documents and Settings\All Users\Application Data\SIM” or, in legacy systems, in the same 
place as the SIM program files (e.g. “C:\InfHome”). 
 
In a network or multi-user environment the SIM database files are stored in a separate folder on a 
network PC or fileserver, e.g. “\\MyServer\InfHome”.  However, it is possible to run single user SIM in 
a network environment. 
 
SIM also allows both of the environments to be set up together on each PC;  then you can choose at 
Login to which SIM database you want to connect. 
 
The general organsisation of this is set out in the following diagram: 
 

 
 
Each SIM database contains references or “pointers” to the TAS Company database(s);  these 
references are set up by you in SIM (see TAS Companies – Configure
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).  Similarly, details of Software 
Modules installed by you and Users are stored by SIM in its database(s). 
 
 
Important – Thin Client Access 
 
In a multi-user Thin Client environment, such as Terminal Services, WinConnect, Citrix etc, it is 
important to have the correct database engine deployed - see the Database System section in the 
Appendices for more information. 
 
The exact implementation, including folder structures, depends on whether or not the Thin Client Host 
Server is also the database host. 
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2 Quick Start 
 
This section explains how to quickly install and set up SIM, add a TAS company, install a software 
module, grant User Access Rights and run the module for that company. 
 

Important – Network Paths 

 
To help avoid confusion in Network installations it is strongly recommended that 
UNC paths are used instead of mapped drive letters. 
 

\\OurServer\TB3Data\Data1 instead of T:\Data1. For example:  
 

 
 
The procedures in Step 1 and 2 also apply if you are upgrading an existing SIM installation.  
However, when you Login to SIM for the first time after the upgrade you will be presented with the 
SIM Upgrade form (see below). 
 

Step Action Notes 

1. Have the Minimum Requirements as per the 
Infoplex web page relating to hardware and 
software, such as 

1 Make sure you have the PC set up and started 
correctly. 
 

a. TAS If upgrading SIM, do NOT uninstall your existing 
copy first. b. .NET Framework 

c. any pending Windows Updates 
2. are logged in as a Local Administrator 
3. have Anti-virus turned off 

2 Install SIM onto your computer using the 
installer .exe file downloaded from the Infoplex 
website. 

Just double click the downloaded installer .exe file to 
start the process. 

3 Login into SIM as the ADMIN user User Name = ADMIN, password = ADMIN  

4 Do the basic setup in SIM as described in steps 
5 to 8 below 

For full details see Initial Setup & Launch in this 
manual 

5 Install at least one TAS company, preferably a 
test/demo company in the first instance 

use the Tools>TAS Companies>Configure function; 
remember the Important – Network Paths note above 

6 
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Install one or more Software Module(s) from 
within SIM 

use the Tools>SIM Modules>Configure function 

7 Integrate the Software Module(s) to at least one 
company, preferably the Test/Demo company 
initially 

use the Tools>SIM Modules>Configure>Integrate 
function 

8 Add access rights for each valid user in SIM for 
the Software Module(s) per company 

using the Tools>SIM Users>Configure Access 
Rights function 

9 Simply select the Company and Launch the 
software module at it 

Double click the required target Company in the main 
SIM Company Selections form and click the Launch in 
the Modules Run form 

10 Use the Company Options functions from the 
software module’s Setup menu 

Important – If this is the first time that the 
Software Module has been used in this 
company, you must now configure the default 
values in order that Module functions work 
correctly 

11 Close the Software Module and then close SIM  

 



Infoplex Ltd Reference Manual System Integration Manager 
 

 
Version 4.50, 20 Oct 2009  Page 10 

3 Versions, TAS Compatibility & Standards 
 
3.1 Products and Versions 
 
The product version(s) covered by this document are:  
 
 

Infoplex Product Version 

System Integration Manager (SIM) 4.50 
 
 
3.2 TAS Product Version Compatibility 
 
The product(s) listed above are for use with TAS 32-bit Windows products as set out in the table 
below.  To check which Data Version your TAS product is:  login to TAS, on the menu go to Help > 
About, select the Product Information tab, left-click the ‘System’ item in the left-hand pane and you 
can see the Data Version in the right-hand pane (last item). 
 

TAS Product 
Latest Data Version 
supported by SIM 

Earliest Data Version 
supported by SIM 

TASBooks (inc Stock module) 1.20 1.20 

FirstBooks 1.20 1.20 

TAS BOOKS 3 8.17 4.07 

TAS BOOKS 2 8.17 4.07 

TAS BOOKS 1  8.17 4.07 

TAS Bookkeeper n/a n/a 

TAS Books Small Business Edition n/a n/a 

TAS Business Controller n/a n/a 

TAS Books Accounting Plus n/a n/a 

TAS Books Accounting n/a n/a 

 
Except where the context requires otherwise all TAS 32-bit Windows accounting systems are from 
here on referred to simply as “TAS”. 
 
 
3.3 Standards 
 
Unless stated otherwise, the system is written to conform broadly to the same general standards 
utilised by TAS so that there is a common look and feel, whilst maintaining adequate security.  These 
include user access security via SIM and the use of function keys. 
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4 Installation 
 
 

Important – Upgrading SIM? 

 
The same procedure applies for both New Installations and Upgrades of existing 
installations. 
 

Do NOT uninstall SIM before upgrading! 
 

 
 
Before starting the installation, please make sure that: 

1. your computer meets the minimum System Requirements, as per the Infoplex website 
download page for hardware and software components, such as 

a. Memory and temporary free disk space 
b. TAS; 
c. .NET Framework; 
d. any pending Windows Updates; 

2. you are logged in to the computer as a Local Administrator; 
3. you have the computer’s Anti-virus turned off. 

 
 

www.infoplex.co.ukYou can install SIM either from a download from the  website or, by special 
arrangement, via a CD/DVD sent to you.  NB: there are additional charges for CD media production 
and delivery. 
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# Source What to do 
1 Website download Double click the SIM Installation program file, e.g. 

“SIM_4.50.183_Release_1.exe”, which you saved to your hard disk 
during the download from Infoplex’s website. 

2 CD/DVD media Insert the the CD/DVD into your CD-ROM/DVD drive.  If the Windows 
"Auto-run" feature is enabled on your computer the SIM Installation 
program starts automatically – it is called something like 
“SIM_4.50.183_Release_1.exe”. 
In case it does not start use the Windows Start>Run utility and click the 
Browse button to browse for and find the SIM Installation program file 
on the CD.  Click OK to start it. 

 
 
The SIM download page gives full step-by-step installation instructions with screenshots.  These are a 
few important points to note: 
 

# Point to Note 
1 The installation starts with the Software License Agreement form.  To continue with 

the installation you must confirm your acceptance of this. 
2 You are given the option to change the default installation folder for SIM.  Unless 

there are special overriding reasons not to, IT IS STRONGLY RECOMMENDED that 
you accept the default and click Next.  However, in exceptional circumstances, click 
Change to change the installation folder. 

3 If you have an earlier version of Btrieve/Pervasive installed the installer invokes the 
Pervasive PSQL v9.5 client installer, unless you are running Windows Vista, in which 
case you must use PSQL v10. 

 
 

http://www.infoplex.co.uk/
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5 Launch, Initial Setup, Login/Logout & Upgrade 
 
 
5.1 Launching SIM 
 
If this is your first SIM installation a new SIM shortcut icon is now available on your desktop: 
 

 
 
Double click the shortcut to launch SIM and, depending on the situation, get to: 
 
The Initial Setup form for this PC, or 
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The Upgrade form, or 
The Login form. 
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5.2 Initial Setup 
 
5.2.1 SIM database folder 
 

Important – Network Paths 

 
To help avoid confusion in Network installations it is strongly recommended that 
UNC paths are used instead of mapped drive letters. 
 

\\OurServer\TB3Data\Data1 instead of T:\Data1. For example:  
 

 
on this PCIf this is the first time SIM has been run  you are presented with the following Setup form 

(if not, you are presented with the Login form - see below): 
 

 
 
There are three self-explanatory options, but the following table helps clarify these options and bear in 
mind that both a Local setup and a Network setup can co-exist on the same workstation: 
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Setup Type Notes & Remarks 
Network Use this on the first "client" workstation for the "once-only" initial setup of the SIM 

databases for network access, normally in a multi-user deployment.  The SIM folder 
"Infhome" containing its database files is created in the folder/location that you specify.  As 
stated above it is strongly recommended that you use UNC rather than a drive letter to 
specify the folder;  do this by using Network Neighbourhood or My Network Places. 
Note - this setup can also be added from within SIM after a Local setup has been created on 
the workstation (see below). 

Network Client Use this for the second and any subsequent "client" workstations in a network deployment. 
Note - this setup, too, can be added from within SIM after a Local setup has been created 
on the workstation (see below). 

Local Use this for a separate or standalone SIM deployment. 
Note - this setup, too, can be added from within SIM after a Network setup has been created 
for the workstation (see above). 

 
Select the appropriate radio button and click Continue to proceed. 
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5.2.2 SIM Activation 
 
SIM and the software modules can be used for up to 30 days without being permanently activated 
(registered), though certain processing restrictions apply.  After this period, to continue to use SIM 
and one or more modules, you must register them. 
 
If this is the first time SIM is being run on your system, you need to activate SIM by entering your 
Licensee name and the associated Activation Code as shown on the form below.  The Activation 
Code can be for a trial or for registering SIM (i.e. permanent activation). 
 

 
 

AWhen you have entered your Licensee name and Activation code, the ctivate button becomes 
enabled; simply click it to continue. 
 
You are asked to confirm that the system date is today's actual date: 
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Click Yes to continue. 
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Then you need to confirm that the Setup type you chose is correct: 
 

 
 
Click Yes to continue.  If you chose Network Setup, you must browse to select the location on the 
network in which the "InfHome" folder is to be created (for the SIM database files): 
 

Important – Network Paths 

 
To help avoid confusion in Network installations it is strongly recommended that 
UNC paths are used instead of mapped drive letters. 
 

\\OurServer\TB3Data\Data1 instead of T:\Data1. For example:  
 

 

 
 
Click the OK button to continue to the main Login screen (see below). 
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5.3 Login/Logout 
 
 
5.3.1 Login 
 
To gain access to SIM each user must enter a valid User name (ID) and Password (not case 
sensitive), and then click the Login button or press Enter.  If you are running SIM for the first time, 
use the permanently setup user "ADMIN" (password = "ADMIN");  you can change ADMIN's 
password later, as well as add other users. 
 

 
 
This form also displays other important information: 
 
• Whether Login is to a “Local SIM database” or a “Network SIM database” (in the first field); 
• the SIM program version, e.g. “v4.50” (bottom left of the form). 
• The SIM Database location (in the status bar at the bottom of the form), e.g. 

“SIM Database: C:\Documents and Settings\All Users\Application Data\Infoplex\SIM” or, 
in legacy versions, “C:\InfHome”. 

 
If SIM has been set up for both Local and Network use, you will be able to select which one you want 
to connect to via a dropdown selection box for the first field – or press Control+L or Control+N.  You 
cannot access both Local and Network SIM simultaneously. 
 
A successful Login takes you to SIM’s Main Company Selection form.  However, if you have just 
installed a SIM upgrade, but the SIM Database to which you are connecting has not already been 
upgraded, you are presented with the Upgrade form (see below) which must be completed first. 
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5.3.1.1 Local Database Login 
 

 
 
 
5.3.1.2 Network Database Login 
 

 
 
 
5.3.2 Logout 
 
You can logout of SIM by closing it using the Window close X button;  this closes SIM entirely.  
Alternatively you can use File>Logout or File>Login (or Control+L) from the main Company 
Selection form’s menu. 
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5.4 Upgrade 
 
If you have just installed a SIM upgrade on this PC, but the SIM Database to which you are 
connecting has not already been upgraded, you are presented with this self-explanatory Data Version 
Upgrade screen is displayed: 
 

 
 

UTo complete the upgrade process enter the "ADMIN" user's current password and click the pdate 
Now button or press Enter.  SIM asks you to confirm that you wish to upgrade: 
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Click Yes to continue. 
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SIM now updates its Local or Network databases, depending on which SIM database you selected, 
and displays a message for you: 
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Click OK to continue to the the main Login screen (see below). 
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6 Main Company Selection Form 
 
 
6.1 Companies 
 
Once you have logged in successfully you are given the main Company Selection form.  Unless there 
are messages for you, in which case the M
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essages Log tab is presented, the Companies tab is 
active. 
 

 
 
The Companies tab lists one or more companies which have been set up in SIM.  You can select a 
company double clicking on it or clicking once on it and pressing the Open button. This opens up a 
new SIM Modules to Run window which allows you to select from a list of software modules which 
have already been integrated to the selected company. 
 
6.2 Message Log 
 
The Message Log tab contains any important messages for you, including notifications of new 
software availability. 
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6.3 Launching a Software Module 
 
Simply select and double click the Software Module you want to run from the list: 
 

 
 
At launch, SIM checks the program’s version number against its database of installed programs.  SIM 
also checks that the TAS Company’s Data version (still) matches that in its own record for the target 
TAS company dataset.  If either of these do not match, you are presented with an error message and, 
to avoid possible data corruption, SIM stops the launch from proceeding further.  As a further security 
safeguard the program cannot be launched successfully directly from Windows; if a user attempts to 
do this, an “Invalid Startup” error message is displayed informing you that the program can only be 
launched from SIM. 
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6.4 SIM Menu & Functions 
 
You can access all SIM functions via the menu bar at the top of the main Company Selection form.  
Each of these produces a drop down sub-menu, with further sub-menus as set out in the following 
table – click on the hyperlinks to jump to the item you want to read about: 
 

Top Menu Dropdown Level 1 Functions Dropdown Level 2 Functions 
Log in - 
Log out - 
Reload Details - File 

Exit - 
TAS Companies Configure (Add, Remove etc)
Software Modules Configure (Add, Remove etc)

Configure (Add, Remove etc)
Configure Access Rights
Log SIM Users out of SIM 
Log SIM Users out of SIM Modules 

SIM Users 

Log TAS Users out of Company 
Crystal Reports Edit Templates 
Activation - 

Tools 

Configuration Options Add Another SIM Database 
SIM Information 
SIM Runtime Information 

Information

System Information 
SIM Manual 
On-Line Support 

Support

Submit Enhancement Request 
Infoplex Homepage 
Infoplex Software Module List 
Infoplex Software Module Compatibility 

Infoplex on the Web

Infoplex Third Party Links 
Check for Updates - 

Help 

About SIM - 
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7 Tools - TAS Companies 
 
7.1 Configure (Add, Remove etc) 
 
This allows the "ADMIN" user, as well as those set up as Supervisor equivalents, to add new links to 
TAS companies, delete companies no longer required, refresh companies' information or even 
change the TAS dataset location for a company.  From the main Selections form click Tools>SIM 
Companies>Configure (Add, Remove etc) to bring up the Maintain Companies form: 
 

 
 
 
7.2 Add TAS Company Link 
 

ATo add a new link to a TAS company click on the dd button then browse for the location of your TAS 
Company data folder, e.g. 
“C:\Documents and Settings\All Users\Application Data\TAS\TASBooks\Company001\Accounts” or 
"C:\TAS Books 3\Data1" 
and click OK.  When the company is set up correctly within SIM, a message saying "The Company 
has been set up successfully" is displayed. When browsing for a TAS data folder on a network server 
it is strongly recommended that you use My Network Places or Network Neighbourhood to get a 
UNC path rather than a drive letter to specify the folder, i.e. "\\OurServer\Data\TASData\…" rather 
than "F:\TASData\…" 
 
 
7.3 Delete TAS Company Link 
 

DTo delete a TAS company link click on the company name, then the elete button and confirm you 
wish to delete the company; once confirmed the company is deleted. 
 
 
7.4 Refresh TAS Company Link 
 
To refresh SIM's database for a TAS company link click on the company name, then the Refresh 
button; any changes relating to the TAS company information are made - for example the version of 
the TAS data if TAS has had a maintenance upgrade applied. 
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7.5 Change Datapath 
 
If you have moved the TAS Company data to another folder, or renamed an existing folder containing 
TAS Company data, click on the company name, then the Change Datapath button, browse for the 
new location of your TAS Company data folder and click OK.  When the company is refreshed 
correctly, a message saying "The Company’s details have been successfully refreshed" is displayed. 
When browsing for a TAS data folder on a network server it is strongly recommended that you use 
My Network Places or Network Neighbourhood to get a UNC path rather than a drive letter to 
specify the folder, i.e. "\\OurServer\Data\TASData\…" rather than "F:\TASData\…". 
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8 Tools - Software Modules 
 
8.1 Configure (Add, Remove etc) 
 
This allows the "ADMIN" user, as well as those set up as Supervisor equivalents, to add new 
Application software modules and to upgrade or remove existing software modules, as well as 
integrate them with (or remove unwanted integrations from) previously set up TAS companies.  From 
the main Selections form click Tools>SIM Modules>Configure (Add, remove etc) to bring up the 
Maintain Software Modules form: 
 

 
 
With (by default) the Applications radio button at the top left of the window checked, you can add, 
upgrade or remove Application software modules.  
 
 
8.2 Add/Upgrade a Software Module 
 
When the Application radio button on the top left of the Maintain Software Modules form is checked 

A
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you can add or upgrade an Application software module by clicking the dd/Upgrade button: 
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Click the Locate Setup File button to locate the installation setup file ("Setup.inf") by browsing for its 
folder.  Once the correct folder has been found the selected software module's name is displayed in 
the dialogue box: 
 
 

 
 
 

o
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Click the C ntinue button to bring up the following dialogue: 
 

 
 
Please read the IMPORTANT notice and, if you agree to be bound by the terms and conditions of the 
Software Licence Agreement, check the box next to the Application software module name, then click 
the OK button and click the Yes button to the Install Verification question (otherwise click the Cancel 
button). 
 
Under certain circumstances SIM requires a special KeyCode to be entered; to obtain this KeyCode 
call Infoplex. Once this has been entered correctly the Application software module installation can 
continue. 
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When the installation is complete the install log is displayed; you can print this by clicking the Print 
button or you can continue by clicking the Close button. 
 

 
 
You can now see that the Application software module is displayed in the modules listings on the 
Maintain Modules and the main Selections forms. 
 
If this is the first installation of the Application software module, you must then integrate it to your TAS 
company (or companies) using the Integrate function described below. 
 
 
8.3 Remove a Software Module 
 
To remove a software module from SIM, select Tools>SIM Modules>Configure (Add, remove etc) 
from the main Company Selection form’s menu, or press Control+M.  Select the Application software 
module you wish to remove, click the Remove button and confirm you wish to remove the module.  A 
message is displayed confirming that the module has been removed. 
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8.4 Integrate 
 
To create an integration between an installed software module and a specific TAS company select 
Tools>SIM Modules>Configure (Add, remove etc) from the main Company Selection form’s menu, 
or press Control+M.  Check the Integrate radio button at the top right of the window to expand the 
form so that you can maintain integration links between application software modules and companies 
 

 
 
 
8.4.1 Add Integration 
 
Select the software module name in the top section, the company name in the bottom section and 
click the Add button to create the integration between the module and the company.  SIM creates a 
new integration record in its database and copies the files needed by the Application module to the 
TAS company's data folder.  
Important: in order to make the new Application/Company integration accessible to users, you must 
use the Tools>SIM Users>Configure Access Rights menu option. 
 
 
8.4.2 Remove Integration 
 
To remove an integration link between an installed software module and a company select 
Tools>SIM Modules>Configure (Add, remove etc) from the main Company Selection form’s menu, 
or press Control+M.  Check the Integrate radio button on the top right of the screen.  Select the 
software module name in the top section, the company name in the bottom section and click the 
Remove button to remove the integration link. 
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9 Tools - Users 
 
9.1 Configure (Add, Remove etc) 
 
Go to Tools>SIM Users>Configure(Add, Remove etc) from the main Company Selections form 
menu, or press Control+U, to get the Maintain Users form which lists the users that have already 
been set up: 
 

 
 
Here you can Add, Edit, Logout, Discontinue and Reinstate users. 
 
Important: only the “ADMIN” user can edit the “ADMIN” user from this form – indeed the “ADMIN” 
user is not even listed when other authorised users view this form 
 
 
9.1.1 Add 
 
To add a user to SIM click the Add button on the Maintain Users form to display the screen below: 
 

 
 
Enter the details for the user in the respective fields. Currently the Email Address is not a required 
field; however the User ID, User Name and Password are.  The User ID is what the user types to log 
in to SIM; the User Name is usually the user’s first and last names; the password is the SIM Login 
password.  To configure how the user accesses software modules and companies click the 
Configure Access Rights… button which is enabled once the required fields are entered. 
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If the user needs to be able to Maintain Companies, Software Modules and other Users, you must 
grant Supervisory rights by clicking the Yes radio button next to Supervisor User?. The user 
Discontinued radio button is used to prevent the user from using SIM - if set to Yes the user is not 
allowed to log in to SIM.  Once you are happy with the users details click the OK button to create the 
new user record, which then appears in the list on the Maintain Users form. 
 
 
9.1.2 Edit 
 
To edit a user select the user in the Maintain Users form and click the Edit button for the screen 
below to be displayed: 
 

 
 
Edit the existing user details, apart from User ID and click the OK button to save the changes. 
 
NB: the "ADMIN" user has Supervisory Rights rights by default.  This cannot be changed. 
 
 
9.1.3 Discontinue User 
 
To discontinue a user select the user in the Maintain Users form and click the Discontinue button; 
the value in the user's record under the "User Discontinued" column changes from "No" to "Yes". 
 
Important: the "ADMIN" user cannot be discontinued. 
 
 
9.1.4 Reinstate User 
 
To reinstate a discontinued user select the user in the Maintain Users form and click the Reinstate 
button; the value in the user's record under the "User Discontinued" column changes from "Yes" to 
"No". 
 
 
9.1.5 Log out User 
 
Use the Logout button/function on the Maintain Users form to log out a user if for some reason, such 
as a system crash or SIM terminating abnormally, the user was left logged in;  the value in the user's 
record under the "Logged In" column changes from "Yes" to "No". 
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9.2 Configure User Access Rights 
 
To maintain Users' Access Rights in SIM go to Tools>SIM Users>Configure Access Rights to 
display the User Access form: 
 

 
 

UserIn the  box enter the User Name of the user whose access rights are to be added or changed.  
You can use the standard Usernavigation and lookup or click the  hyperlink to find and select the 
user. 
 
The options then available from the buttons are as follows, depending on what has already been set 
up: 
 Add – adding a new set of user access rights for an Application/Company; 
 Edit – editing current existing user access rights for an Application/Company; 
 Logout – logging the user out of the selected Application/Company; 
 Discontinue – discontinue the user from having access to the selected Application/Company; 
 Reinstate – reinstate a discontinued user to allow him/her to use the selected 

Application/Company again. 
 
Each of these is described in more detail in the following sections below. 
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9.2.1 Add User Access Rights 
 
To add access rights for the selected user in the top selection box, select the Application/Company 
for which access rights are to be added; then click the Add button to display the following form: 
 

 
 
To assign access rights simply click in the checkbox next to each function for which access is 
required.  You can assign Supervisory rights over the Application/Company to the user by clicking the 
Yes radio button in the Supervisory Rights section. The Edit/Delete Rights section is not used in 
this version of SIM 
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9.2.2 Edit User Access Rights 
 
To edit access rights for the selected user in the top selection box, firstly select the application the 
access rights have to be edited for.  Then click on the Edit button to display the following form. 
 

 
 
Again to alter the current rights check/uncheck the Access Options on the left to suit for the user and 
also the supervisory rights if they are to be changed. 
 
 
9.2.3 Discontinue User Access Rights 
 
To discontinue a user’s access to an Application/Company select the user in the User Access form 
and click the Discontinue button; the value in the user’s record under the “User Discontinued” 
column changes to “Yes”. 
 
 
9.2.4 Reinstate User Access Rights 
 
To reinstate a discontinued user select the user in the User Access form and click the Reinstate 
button; the value in the user’s record under the “User Discontinued” column changes from “Yes” to 
“No”. 
 
 
9.2.5 Log Out 
 
Use the Logout button/function on the User Access form to log out a user if for some reason, such as 
a system crash or an Application software module terminating abnormally, the user was left logged in; 
the value in the user’s record under the “Logged In” column changes from “Yes” to “No”. 
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9.3 Logout Users – future development 
 
There are 3 other menu items relating to SIM users.  Currently they are work in progress and will be 
available in future releases of SIM.  Clicking on any of these options will currently give you a message 
advising that this is currently “Work In Progress”.  The 3 options are: 
 

1. Log SIM Users out of SIM 
2. Log SIM Users out of SIM Modules 
3. Log TAS Users out of Company 

 
 
 
10 Tools - Crystal Reports Designer Tool 
 
This innovative tool is the very first of its kind for TAS.  Normally, TAS uses Microsoft Word to let you 
customise documents such as quotations and invoices, but this has a number of limitations and can 
often prove difficult and awkward.  
 
The advanced document processing and reporting capability of MultiTAS and OrderBooks, using 
Crystal Reports, provides a convenient and sophisticated way for you to handle sales documents, 
invoice posting, sales analysis, stock reporting or price lists, and means that you can easily customise 
these documents with a minimum of fuss, and then issue them via email, effortlessly. 
 
In addition, you can print weights, both for individual items and document totals, as well as counts of 
the number of items for delivery documents.  This means that you can produce the total weight of a 
package on a delivery note or that you can place the total number of items on a delivery label – all by 
simply using a Crystal Reports formula. 
 
You can preview documents before committing them to printer or file (PDF, Excel, Word etc), to email 
or to another application.  You can also generate customer-specific price lists based on TAS product 
prices and dynamic discounts with no trouble, using customisable report templates to change the 
layout, insert a company logo, or even print pictures of products or barcode labels. 
 
The Crystal Designer tool allows you to maximise the benefits of TAS using the industry standard 
database reporting tool: Crystal Reports.  This proven globally renowned solution helps you to design, 
manage and deliver reports from a wide range of data sources, such as the web or that are 
embedded in other applications. 
 
Full details of how to use the Crystal Designer can be found in the Appendix. 
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11 Tools - Activation – Trial, Register or Upgrade 
 
SIM and the software modules can be used for up to 30 days without being permanently activated 
(registered), though certain processing restrictions apply.  To continue to use SIM and one or more 
modules, you must register them.  To do so, go to Tools > Activation (or press Control+A) for the 
Activation form: 
 

 
 
The form displays, in column format, SIM and all the software modules that you have installed, 
together with current Licence details and status.  Any unregistered products default to a ticked check 
box for ‘Initial Registration’ and ‘Register’ as the ‘Requested Action’ (you can uncheck this if you 
want). 
 
With appopriate Activation Codes from Infoplex you can undertake various licence-related 
procedures: 
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# Activation Procedure Note 
1 Initial Registration Of SIM itself and/or one or more software modules 
2 Extend Support So that up-to-date SIM and software modules can be 

installed 
3 Upgrade From Single User/Company to Multi-User/Company 

and/or enable Special Features (where a software 
module has one or more Special Features) 

4 Enable a new Trial Of a software module with or without Multi-
User/Company and/or any other Special Feature(s)  

5 Extend an existing Trial  
 
If you want to try out Multi-User/Company features or any available Special Features, just contact 
Infoplex Customer Services separately by telephone, email or fax. 
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11.1 Request Registration 
 
To register SIM or a software module permanently an appropriate Activation Code has to be 
obtained and entered for each;  these codes are issued by Infoplex.  To obtain activation codes for 
SIM and/or module(s), simply follow the steps described below. 
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Step Action 
1 If this is an initial SIM registration, in the ‘Licensee Name’ box enter the name of the 

Licensee to whom SIM is to be registered;  normally this will be the name of the 
business/company which purchased the software. 

2 Select the product(s) and type(s) of activation you require, e.g. Users, Companies and 
Special Features. 

3 Click the Print Registration/Upgrade Request Form button to print the request; you 
will be given the option to preview the request before printing and keep an electronic 
copy. 

4 Complete, sign and fax or scan/email the Request form printout to Infoplex to obtain 
the activation code (the fax number is on the form). 

 
 
11.2 Activate Registration 
 
Infoplex will send the requested Activation Code(s) normally by email, though fax can be an 
alternative.  (In the future you may be able to obtain the Codes via the website.) 
 
Emailed Activation codes comprise an XML file attachment to the email.  Simply save the attachment 
to your local SIM program folder (by default “C:\Program Files\Infoplex\SIM” or, in legacy systems, 
“C:\InfHome”), or to your desktop, and use the same Activation form to apply the codes by clicking the 
Import SIM Activation Script… button to bring up the Open dialogue to get the XML file:  
 

 
 
When you have found and selected the XML file, click Open to import the registration code(s). 
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Alternatively, you can dispense with the Open dialogue by dragging the XML file from your desktop or 
another folder directly onto the Activation form.  Either way, if the XML file is valid for your system, 
you receive this message: 
 

 
 
Another option is for you to manually enter the code(s) supplied by Infoplex directly into the form. 
 

 
 
If you do this, it must all be entered exactly as faxed/emailed by Infoplex;  any error causes the 
activation to fail (invalid codes are highlighted in red, rather than green for valid ones) – if you are 
activating the the initial SIM registration, it is important to note that the Licensee Name is case 
sensitive. 
 
Finally click the Apply button to save the new Activation Code(s).  You will get a message to confirm 
that this was successful. 
 

 
 
The Activation form refelects the resulting changes, e.g. the new Support Expiry Date. 
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12 Tools - Configuration Options 
 
12.1 Add Another SIM Database 
 
If access to a local or network version of SIM was not set up initially you can use 
Tools>Configuration Options>Add Another SIM Database.  The procedure is identical to the 
procedure set out in the SIM Setup section (see above) for both an initial (new) Network Setup or, 
more simply, a Network Client Setup for this workstation. 
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13 Help 
 
The Help system is available whether or not you are logged into a SIM database. 
 
 
13.1 Help > Information 
 
The SIM Information, SIM Runtime Information and the MS System Information programs are 
very important tools for gathering information, troubleshooting and enabling good quality support to be 
provided. 
 
 
13.2 Help > Support 
 
The SIM Manual (this document), available in Acrobat *.pdf format (press F1), together with On-Line 
Support (press Shift+F1), provide vital support information. 
 
Use Submit Enhancement Request to automatically generate a “Wish List” request to Infoplex via 
the website. 
 
 
13.3 Help > Infoplex on the Web 
 
Four links are provided which let you get additional information and which launch your default Web 
Browser:  

1. Infoplex Home Page, 
2. Infoplex Software Module List 
3. Infoplex Software Module Compatibility and 
4. Infoplex Third Party Links. 

 
 

http://www.infoplex.co.uk/support.htm
http://www.infoplex.co.uk/support.htm
http://www.infoplex.co.uk/simenhancementrequest
http://www.infoplex.co.uk/
http://www.infoplex.co.uk/simmodules
http://www.infoplex.co.uk/simmodulecompatibility
http://www.infoplex.co.uk/thirdparty
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13.4 Help >Check for Updates 
 
Use this function to find out if you have the most up to date SIM release running and to check for any 
other important customer messages from Infoplex.  It only works if you have a working internet 
connection. SIM checks online to the Infoplex website.  If there are any messages, they are displayed 
in the Message Log list, like the last two messages in this example: 
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13.5 Help > About SIM 
 
This gives you basic information about SIM and contact details for Infoplex: 
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APPENDIX A Crystal Reports - Customising Documents 
 
 
A.1 Introduction to Crystal Report Designer Tool 
 
This innovative tool is the very first of its kind for TAS.  Normally, TAS uses Microsoft Word to let you 
customise documents such as quotations and invoices, but this has a number of limitations and can 
often prove difficult and awkward.  
 
The advanced document processing and reporting capability of MultiTAS and OrderBooks, using 
Crystal Reports, provides a convenient and sophisticated way for you to handle sales documents, 
invoice posting, sales analysis, stock reporting or price lists, and means that you can easily customise 
these documents with a minimum of fuss, and then issue them via email, effortlessly. 
 
In addition, you can print weights, both for individual items and document totals, as well as counts of 
the number of items for delivery documents.  This means that you can produce the total weight of a 
package on a delivery note or that you can place the total number of items on a delivery label – all by 
simply using a Crystal Reports formula. 
 
You can preview documents before committing them to printer or file (PDF, Excel, Word etc), to email 
or to another application.  You can also generate customer-specific price lists based on TAS product 
prices and dynamic discounts with no trouble, using customisable report templates to change the 
layout, insert a company logo, or even print pictures of products or barcode labels. 
 
The Crystal Designer tool allows you to maximise the benefits of TAS using the industry standard 
database reporting tool: Crystal Reports.  This proven globally renowned solution helps you to design, 
manage and deliver reports from a wide range of data sources, such as the web or that are 
embedded in other applications. 
 
A basic knowledge of using Crystal Reports is assumed. 
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A.2 Starting the Crystal Report Designer Tool 
 
Click Tools>Crystal Reports>Designer (or Ctrl+E) to start the Crystal Report Designer tool, which 
presents you with a “[New]” empty designer canvas as shown below.  It is intended for use with 
Crystal Reports Templates relating to Infoplex’s MultiTAS and OrderBooks software products. 
 

F
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You can retrieve an existing Template by clicking on the Open File icon or on the menu item ile > 
Open.  Use the browse dialogue to find the folder and file you want to work with.  All these Templates 
have the file extension ‘.RPT’. 
 

 
 
 
 
A.3 Getting Crystal Designer Help 
 

HClicking the menu item elp > Contents gives you access to the comprehensive Crystal Reports 
Online Help facility. 
 
Here you can use the powerful Contents, Index and Search resources to find just what you need. 
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A.4 Retrieving an existing Crystal Template 
 

F
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Click on the Open File icon or on the menu item ile > Open.  Use the browse dialogue to find the 
folder and file you want to retrieve. 
 
In the example below, the Infoplex Standard Picking List “StanPic1.rpt” (used in MultiTAS and 
OrderBooks Sales Order Document Processing) has been retrieved.  The program opens it in the 
Designer tab: 
 

 
 
Note that the various different Field Types are listed down the left-hand side: 

• Database Fields 
• Formula Fields 
• Parameter Fields 
• Group Name Fields 
• Running Total Fields 
• Special Fields 
• Unbound Fields 

 
You can drag fields around the canvas and format them (right-click on the field) to suit your needs. 
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A.5 Inserting a new Database Field 
 
To insert a new Database field from, for example, the Document Header workfile, expand the 
Database Fields item by clicking the “+” sign next to the table called “OrdDocHdrWork1”.  The table 
and the field lists for each table/file are held within the “StanPic1.rpt” file and are displayed for 
selection: 
 

 
 
Fields already on the report are ticked (they can be used more than once).  Simply drag the field that 
you want onto the canvas. 
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A.6 Adding your Company Logo 
 

Click the insert picture button .  Use the browse dialogue to find your logo file and click Open to 
catch it in the Designer.  Move the mouse to where you want to place it and click to place it there. 
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A.7 Print Preview 
 
Click the Preview tab to display your data in Preview mode in a similar way to the SO Document 
Processing function in OrderBooks and MultiTAS – you can even print or export it: 
 

 
 
To give your newly Customised Template its own filename use the >File>Save As option. 
 
If you wish you can store all your Crystal *.RPT files in a separate Template folder to suit yourself – 
just remember to tell the SIM Module using >Setup>Document Templates, which can now be used 
to add your new Template to the list of those available. 
 
Under certain circumstances you may encounter an error, as below, when previewing.  The 
workaround is to create the “missing” folder and copy the files called “..W1.BI” into it. 
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APPENDIX B Database System 
 
 
B.1 Introduction 
 
TAS, SIM and Infoplex software modules use the Pervasive/Btrieve database engine.  From TAS 
BOOKS v8 in July 2008, TAS shipped with the Pervasive “Summit” (PSQL v10.10) database which is 
installed on each PC with the TAS product(s).  Before that a basic Btrieve v6.15 workstation engine 
shipped with all copies of TAS. 
 
Pervasive PSQL allows TAS and Infoplex software to be much more scalable, fast and reliable 
than any other popular business system in UK and Ireland – you can scale it up to 100’s or 
even 1,000’s of users.  You can also use the software in “thin client” environments, such as 
Terminal Services, WinConnect or Citrix. 
 
SIM uses the latest version of the Pervasive PSQL Client Requesters and related developer 
components, such as the Pervasive ActiveX controls.  All Pervasive Requesters are currently 
backwards-compatible as far back as the Btrieve v6.15 workstation engine, provided that this Btrieve 
is not running on Windows Vista/7/2008. 
 
However, because Pervasive/Btrieve is such a widely used database, especially among accounting, 
banking and similar ‘mission-critical’ applications, there are many different possible combinations of 
database engine type and client requester.  Your PC and, if you run multi-user TAS over a network, 
the remote ‘server’ could therefore have either Btrieve or Pervasive already installed. 
 
The SIM installer takes into account what is already installed on your PC(s) and adjusts the 
Pervasive/Btrieve installation accordingly.  However, it does not install any database engine. 
 
 
B.2 Pervasive/Btrieve Versions 
 
The various versions and models of Pervasive/Btrieve are summarised in this table: 
 

Version Name(s) Approx Date Workstation Workgroup Client/Server 
6.15 Btrieve v6.15 1996 Win32 n/a Windows Server 

NetWare 
7.x Pervasive.SQL V7, 2000 

and 2000i 
1998- 
2001 

Win32 Win32 Windows Server 
NetWare 
Linux 

8.x Pervasive.SQL V8 2002 n/a 
(Workgroup 
replaces) 

Win32 Windows Server 
NetWare 
Linux 

9.x Pervasive P.SQL v9 2005 n/a 
(Workgroup 
replaces) 

Win32 Windows Server 
NetWare 
Linux 

10.x Pervasive Summit 2007 n/a 
(Workgroup 
replaces) 

Win32 & Win64 Windows Server 
Linux 
(32-bit & 64-bit) 

 
 
B.3 Multi-User Systems 
 
Care is required in deploying multi-user systems, whether they are implemented in true multi-user 
network environments (Windows Server, Linux and NetWare) or in Peer-to-Peer networks (Windows 
XP or Vista Workgroups).  This is especially the case where more than 3-4 concurrent users are 
involved, or with as little as 2 concurrent users in heavy data processing environments. 
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APPENDIX C Database Navigation, Lookups & Function Keys 
 
The main function keys operate in much the same way as TAS: 
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Key Function Description 
Database navigation – Lookup Selection list F2 
Database navigation – Find First/Last/Prev/Next F5, F6, F7 & F8 
Database navigation – Find Nearest F9 
Record management – Clear form F3 
Record management – Delete F4 
Record management – Save F10 
Reserved for special functions F11 & F12 

 
 
A sample Lookup selection list form is included and shown below, though its actual presentation will 
vary in certain respects depending on the type of Lookup you are doing. 
 

 
 
Depending on the type of Lookup that you are performing you may have options for how you want to 
search using the Search by dropdown menu; for example you may be able to search Customers by 
their TAS Code, their Name or their Postcode.  Partially typing in the search field makes the nearest 
match appear in the first row of the grid.  You can also use the 4 database navigation buttons on the 
right of the form, the top and bottom one of which take you to the first and last record of the Search 
By field.  Double clicking on a column header sorts the displayed list in ascending/descending order. 
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The following table sets out the columns which are displayed for different types of lookup and which 
are searchable: 
 

Lookup Table Display Columns Searchable 
Code 3 
Name 3 
Postcode 3 
Group 3 
Marketing Code 3 

Customers 

Salesperson 3 
Delivery Code  

Name  

Postcode  

Contact  

Customer Delivery Addresses 

Tel Num  

Code 3 
Name 3 
Postcode 3 

Suppliers 

Group 3 
Group Code 3 Customer & Supplier Groups 
Description  
Code 3 Marketing Codes 
Description  
Code 3 
Description 3 
Group 3 
Bin 3 
ANA/Barcode 3 
Type 3 
Discontinued  

Products 

Price 1  
Group Code 3 
Group Description  

Product Groups 

Number of Products in Group  
Sales Order Number 3 
Customer Code 3 
Order Type 3 
Sub-Type  

Description  

Order Date 3 

Sales Orders 

Expected Ship Date 3 
Code 3 
Name  
Tel Num  
Area Covered  

Salespersons 

Country Covered  
Code  Free Format Text Blocks 
Description  

Nominal Account Number 3 
Department  

Description 3 

Chart of Accounts 

Group 3 
Rate ID 3 
Description  
Percentage  
Nominal Account Number  

VAT Rates 

Nominal Department  
Bank Account Number 3 
Bank Account Name  

Nominal Account Number  

Bank Accounts 

Nominal Department  

ISO Country Code 3 
EC Country Code 3 
Name 3 

Countries 

Notes  

Code 3 
Name  

Currencies 

Rate  
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Lookup Table Display Columns Searchable 
3 Order Number 

Supplier Code 3 
Purchase Orders 

Description  
3 Order Date 

Expected receipt Date  

Order Completed?  
3 Invoicing Completed? 
3 Supplier’s Order Number 

User Name SIM Users  

 
 
In future versions you will be able to select which columns you want to display from a list: 
 

 
 
 
For other functions, such as to move around forms, use: 
 

Key Function Description 
Accept an entry and move to the next field  TAB 
Move to the next field – Up, Down, Left, Right , , ,  
Insert blank row on grids Ctrl + Insert 
Delete row on grids Ctrl + Delete 
Microsoft standard Print dialogue box Ctrl + P 
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APPENDIX D Files/Tables Used 
 
The above functions use the data files/tables listed below as summarised in the table. 
 

File/Table Type Notes/Remarks Function #s 
INFCENT.B PSQL/Btrieve SIM Central Information Login 
INFAPPS.B PSQL/Btrieve SIM Application Software Module Modules, Launch 
INFCOMPS.B PSQL/Btrieve SIM TAS Companies Company Config 

INFAPPCO.B 
PSQL/Btrieve SIM Application Software Module to TAS 

Company integrations 
Modules Integrate 

INFOPTS.B PSQL/Btrieve SIM Application Software Module Launch 
INFUSER1.B PSQL/Btrieve SIM Users Users, Login 
INFUSER2.B PSQL/Btrieve SIM User>Software Module>TAS Company Access, Launch 
INFMENUS.B PSQL/Btrieve SIM Application Software Module Menus Access, Launch 
INFERRB.B PSQL/Btrieve SIM database errors All 
AppCent.BI PSQL/Btrieve Application Software Module Central 

Information 
All 

DocGblW1.BI PSQL/Btrieve Report document’s global runtime information 
workfile 

All Reporting 

xxxxWK1.BI PSQL/Btrieve Xxxxxx Report data workfile Some Reporting 
Xxxxx.LOG ASCII Text ASCII Text Log file General 
Xxxxx.XML XML Activation codes from Infoplex Activation 
Xxxxx.TXT ASCII Text ASCII Text Log file Module Install 
Xxxxx.DAT ASCII Text/CSV Data records in basic format Runtime Info 
TAS Central Information PSQL/Btrieve To get TAS Company core information Company Config 
TAS Version PSQL/Btrieve To get TAS data version information Company Config 
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APPENDIX E Change History 
 
 

Version Build Date Feature Add/Change Notes 

1 25/01/00 First release.   

2 21/02/00  

1.01 

3 22/03/00  

1 27/08/00  1.02 

2 04/09/00  

1.03 1 16/01/01  

1 24/07/01  

2a 10/09/01  

2b 11/10/01  

1.04 

3 10/03/03 Also known as build 2c 

2.01 2 01/05/03 Build 1 not released.  New Support features added. 

3.01 5 05/05/06 Builds 1-4 were internal/beta.  Major makeover, especially to startup and Login, Activation 
and ability to incorporate software module’s Special Features 

3.01 6 09/08/06 Made compatible with v6 of the TAS BOOKS range; the installer updated with 
Pervasive.SQL v9.5 (i.e. v9 SP2) client and Crystal Reports v11.0 (i.e. XI) SP2 runtime 
components 

New release compatible with v8 of the TAS BOOKS range 4.0x 5 22/09/08 

the installer updated with Pervasive.SQL v9.5 (i.e. v9 SP2) client components 

Made compatible with new TASBooks v1 and FirstBooks v1 product range 4.50 169 19/10/09 

Links to Infoplex online system via internet to check version against current released 
version and retrieve other messages 
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